Announcement

Collapse
No announcement yet.

Using Facebook ads for Spotify links

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using Facebook ads for Spotify links

    Hi. There's something weird when I was bout to do Facebook ad campaign with a Spotify link.

    I've already created a campaign through traffic and followed the instruction from this link (https://www.youtube.com/watch?v=EgcgvUP8Mrw&t=265s).

    I can see the click was increased, however the Spotify Stream was NOT increased.

    Is anybody facing this, and is there any solution or other advice on this? Hope someone can see my message on this.


    Joseph (from Malaysia)

  • #2
    Originally posted by mashmashforturnzup View Post
    Hi. There's something weird when I was bout to do Facebook ad campaign with a Spotify link.

    I've already created a campaign through traffic and followed the instruction from this link (https://www.youtube.com/watch?v=EgcgvUP8Mrw&t=265s).

    I can see the click was increased, however the Spotify Stream was NOT increased.

    Is anybody facing this, and is there any solution or other advice on this? Hope someone can see my message on this.


    Joseph (from Malaysia)
    I'd go with this video as a guide using conversions instead of link clicks. Traffic campaigns tend to fail very often nowadays so I don't use them anymore.



    The only change I would do from that video is remove Audience Network from the placements.

    Comment


    • #3
      Originally posted by AndrewSouthworth View Post

      I'd go with this video as a guide using conversions instead of link clicks. Traffic campaigns tend to fail very often nowadays so I don't use them anymore.



      The only change I would do from that video is remove Audience Network from the placements.
      Hi Andrew,

      Thanks. I will try conversions ad, and use Toneden for Conversions see whether is working.

      I disabled few placement 'Facebook Group Event' and 'Right Event' (not sure what it is), due to my picture pixel doesn't match from their requirements and quite bothers me. Reason is I tried to change the pixels from their 'Edit' button, and still not working and having errors 4 times I tried.

      Therefore I have to disable it and now it works.


      Joseph (from Malaysia)
      Last edited by mashmashforturnzup; 10-18-2020, 01:27 PM.

      Comment

      Working...
      X